CALC-BEISPIELE    WENN-ODER-FUNKTION        SVERWEIS mit NAMEN       SVERWEIS-Beispiele mit EXCEL


SVERWEIS (S
uchverweis)

Diese Funktion wird verwendet, wenn ein genau festgelegter Bereich z. B. eine Tabelle, die von M1 bis N8 (M1:N8) reicht, nach einem Wert durchsucht werden soll.

Die folgenden Tabelle dient bei unserem Beispiel als "Suchtabelle"
 

A B C D E F
1  Auswertungstabelle
2 Anschläge Punkte Tippfehler Punkte geschriebene Silben Punkte
3 1800 0 0 100 80 0
4 2000 20 2 75 100 20
5 2400 40 4 50 120 40
6 2600 60 6 25 140 60
7 2800 80 8 10 160 80
8 3000 100 10 0 180 100
9            

 

Aufgabenstellung:
Bei einem Test für Schreibkräfte werden die Fähigkeiten in Maschineschreiben und Stenografie bewertet und aus den Einzelergebnissen die Gesamtpunktezahl ermittelt.
Mit der SuchVERWEIS-Funktion werden den Leistungen der Kandidaten die passenden Punkte zugewiesen. 
 
A B C D E F

G

H
11 Name Anschläge Punkte Tippfehler Punkte Silben  Punkte Gesamt
12 Bloch 2320   2   86    
13 Drachsler 1960   5   215    
14 Fröhlich 3006   1   155    
15 Indrak 2634   3   202    
16 Kronberger 2008   4   134    
17 Lorber 2540   0   178    

 

Lösung:
1.
In C12 werden die zu den 2320 Anschlägen "passenden" Punkte mit folgender Formel gesucht:

=SVERWEIS(B12;$A$3:$B$8;2)

in Worten ausgedrückt bedeutet die Formel: suche (=SVERWEIS) zu den Anschlägen in B12 (B12) ; in der Tabelle, die von A3 ($A$3) bis (:) B8 ($B$8) reicht den zugehörigen Wert aus der zweiten Spalte (2). Das sind in diesem Fall 20 Punkte, denn 40 wären es erst ab 2400 Anschlägen.

Das $-Zeichen verhindert, dass sich beim Kopieren der Formel nach unten die Positionsangabe für die Suchtabelle - die ja an der selben Stelle bleibt - ändert.
 

A B C D E F

G

H
11 Name Anschläge Punkte Tippfehler Punkte Silben  Punkte Gesamt
12 Bloch 2320 20 2   86    
13 Drachsler 1960 0 5   215    
14 Fröhlich 3006 100 1   155    
15 Indrak 2634 60 3   202    
16 Kronberger 2008 20 4   134    
17 Lorber 2540 40 0   178    

 

2. In E12 suchen wir jetzt zu den 2 Tippfehlern die Punktezahl:  =SVERWEIS(D12;$C$3:$D$8;2)
Die Suchtabelle für die Tippfehler reicht von C3 ($C$3) bis (:) D8 ($D$8), besteht demnach wieder aus zwei Spalten, der gesuchte Wert steht auch hier in der zweiten Spalte (2).
 
A B C D E F

G

H
11 Name Anschläge Punkte Tippfehler Punkte Silben  Punkte Gesamt
12 Bloch 2320 20 2 75 86    
13 Drachsler 1960 0 5 50 215    
14 Fröhlich 3006 100 1 100 155    
15 Indrak 2634 60 3 75 202    
16 Kronberger 2008 20 4 50 134    
17 Lorber 2540 40 0 100 178    

 

3. Die Formel in G12 lautet  =SVERWEIS(F12;$E$3:$F$8;2)

4. und zum Abschluss noch die Gesamtsumme in H12  =C12+E12+G12

CALC-FUNKTIONEN    WENN-ODER-FUNKTION        SVERWEIS mit NAMEN       SVERWEIS-Beispiele mit EXCEL